Guile warnings printed upon reconfigure due to 3.0/2.2 mismatch

  • Open
  • quality assurance status badge
Details
4 participants
  • Gábor Boskovits
  • Ludovic Courtès
  • Maxime Devos
  • strypsteen
Owner
unassigned
Submitted by
strypsteen
Severity
important
S
S
strypsteen wrote on 26 Jan 2020 12:35
imported module (guix build utils) overrides core binding `delete'
(address . bug-guix@gnu.org)
59c88886464839a973a5d727cdf699b8@posteo.net
Whenever running "sudo guix system reconfigure /path/to/config.scm I get
the following warnings:

building
/gnu/store/vpazjd711byj3jszh7jrk5d8lq51077g-switch-to-system.scm.drv...
;;; WARNING: loading compiled file
/gnu/store/5bd6ywmfcxxa4gvpzg0pdbjwmf24cxkl-module-import-compiled/gnu/build/activation.go
failed:
;;; In procedure load-thunk-from-memory: incompatible bytecode kind
;;; compiling
/gnu/store/p8miza2mpnjdlpmh8504dm9xz2q9nvfr-module-import/gnu/build/activation.scm
;;; WARNING: loading compiled file
/gnu/store/5bd6ywmfcxxa4gvpzg0pdbjwmf24cxkl-module-import-compiled/gnu/build/accounts.go
failed:
;;; In procedure load-thunk-from-memory: incompatible bytecode kind
;;; compiling
/gnu/store/p8miza2mpnjdlpmh8504dm9xz2q9nvfr-module-import/gnu/build/accounts.scm
;;; compiled
/root/.cache/guile/ccache/3.0-LE-8-4.2/gnu/store/p8miza2mpnjdlpmh8504dm9xz2q9nvfr-module-import/gnu/build/accounts.scm.go
;;; compiled
/root/.cache/guile/ccache/3.0-LE-8-4.2/gnu/store/p8miza2mpnjdlpmh8504dm9xz2q9nvfr-module-import/gnu/build/activation.scm.go
making '/gnu/store/iym6z6hkmdc1x0l1vh4bm08vmsiics2p-system' the current
system...
setting up setuid programs in '/run/setuid-programs'...
populating /etc from /gnu/store/8g5f1kbidns7jrqaxqjldkdldl78zv0n-etc...
WARNING: (guile-user): imported module (guix build utils) overrides core
binding `delete'
WARNING: (guile-user): imported module (guix build utils) overrides core
binding `delete'
WARNING: (guile-user): imported module (guix build utils) overrides core
binding `delete'
WARNING: (guile-user): imported module (guix build utils) overrides core
binding `delete'
WARNING: (guile-user): imported module (guix build utils) overrides core
binding `delete'
WARNING: (guile-user): imported module (guix build utils) overrides core
binding `delete'
WARNING: (guile-user): imported module (guix build utils) overrides core
binding `delete'
WARNING: (guile-user): imported module (guix build utils) overrides core
binding `delete'
substitute: updating substitutes from 'https://ci.guix.gnu.org'...
100.0%
building
/gnu/store/pxmi01rf7rpcbgx2j041k01xsr9grm1c-module-import-compiled.drv...
building
/gnu/store/alamdi63ns0ahis93jz1x4cndy4w09gf-install-bootloader.scm.drv...
WARNING: (guile-user): imported module (guix build utils) overrides core
binding `delete'
;;; WARNING: loading compiled file
/gnu/store/62gvwndkddaq6203mrisshgiv13kkgcd-module-import-compiled/gnu/build/bootloader.go
failed:
;;; In procedure load-thunk-from-memory: incompatible bytecode kind
;;; compiling
/gnu/store/wamhgn5mhgzf9mgp9gxx3w6jn64hw4yc-module-import/gnu/build/bootloader.scm
;;; compiled
/root/.cache/guile/ccache/3.0-LE-8-4.2/gnu/store/wamhgn5mhgzf9mgp9gxx3w6jn64hw4yc-module-import/gnu/build/bootloader.scm.go
guix system: bootloader successfully installed on '/boot/efi'
WARNING: (guile-user): imported module (guix build utils) overrides core
binding `delete'
L
L
Ludovic Courtès wrote on 27 Jan 2020 05:04
control message for bug #39301
(address . control@debbugs.gnu.org)
87v9oxhwy4.fsf@gnu.org
retitle 39301 Guile warnings printed upon reconfigure due to 3.0/2.2 mismatch
quit
L
L
Ludovic Courtès wrote on 27 Jan 2020 05:04
(address . control@debbugs.gnu.org)
87tv4hhwy1.fsf@gnu.org
severity 39301 important
quit
L
L
Ludovic Courtès wrote on 2 Feb 2020 13:14
Re: bug#39301: imported module (guix build utils) overrides core binding `delete'
(address . strypsteen@posteo.net)(address . 39301@debbugs.gnu.org)
87blqg66ab.fsf@gnu.org
Hello!

strypsteen@posteo.net skribis:

Toggle quote (11 lines)
> Whenever running "sudo guix system reconfigure /path/to/config.scm I
> get the following warnings:
>
> building
> /gnu/store/vpazjd711byj3jszh7jrk5d8lq51077g-switch-to-system.scm.drv...
> ;;; WARNING: loading compiled file
> /gnu/store/5bd6ywmfcxxa4gvpzg0pdbjwmf24cxkl-module-import-compiled/gnu/build/activation.go
> failed:
> ;;; In procedure load-thunk-from-memory: incompatible bytecode kind
> ;;; compiling

[...]

Toggle quote (16 lines)
> building
> /gnu/store/alamdi63ns0ahis93jz1x4cndy4w09gf-install-bootloader.scm.drv...
> WARNING: (guile-user): imported module (guix build utils) overrides
> core binding `delete'
> ;;; WARNING: loading compiled file
> /gnu/store/62gvwndkddaq6203mrisshgiv13kkgcd-module-import-compiled/gnu/build/bootloader.go
> failed:
> ;;; In procedure load-thunk-from-memory: incompatible bytecode kind
> ;;; compiling
> /gnu/store/wamhgn5mhgzf9mgp9gxx3w6jn64hw4yc-module-import/gnu/build/bootloader.scm
> ;;; compiled
> /root/.cache/guile/ccache/3.0-LE-8-4.2/gnu/store/wamhgn5mhgzf9mgp9gxx3w6jn64hw4yc-module-import/gnu/build/bootloader.scm.go
> guix system: bootloader successfully installed on '/boot/efi'
> WARNING: (guile-user): imported module (guix build utils) overrides
> core binding `delete'

All these warnings are harmless and stem from the Guile 2.2/3.0
transition. Specifically, it comes from the fact that ‘guix system
reconfigure’ evaluates this code with the host Guile (in this case 3.0),
whereas the modules are built for 2.2, which is what the Shepherd
depends on.

The culprit is ‘local-eval’ in (guix scripts system), which simply uses
‘primitive-eval’ to evaluate the code, thus disregarding the Guile
version that should be used.

One possibility would be to instead evaluate the expression in a
separate Guile process for the intended Guile version.

I’m not sure it’s worth it though. The warnings will hopefully
disappear soon when we upgrade everything to 3.0.

Thoughts?

Ludo’.
G
G
Gábor Boskovits wrote on 2 Feb 2020 14:59
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAE4v=piM_pZCnosx88N1RPgVqR8d_znjqvpjzRJx2xqf9_jHZw@mail.gmail.com
Ludovic Courtès <ludo@gnu.org> ezt írta (időpont: 2020. febr. 2., Vas
22:15):

Toggle quote (56 lines)
> Hello!
>
> strypsteen@posteo.net skribis:
>
> > Whenever running "sudo guix system reconfigure /path/to/config.scm I
> > get the following warnings:
> >
> > building
> > /gnu/store/vpazjd711byj3jszh7jrk5d8lq51077g-switch-to-system.scm.drv...
> > ;;; WARNING: loading compiled file
> >
> /gnu/store/5bd6ywmfcxxa4gvpzg0pdbjwmf24cxkl-module-import-compiled/gnu/build/activation.go
> > failed:
> > ;;; In procedure load-thunk-from-memory: incompatible bytecode kind
> > ;;; compiling
>
> [...]
>
> > building
> > /gnu/store/alamdi63ns0ahis93jz1x4cndy4w09gf-install-bootloader.scm.drv...
> > WARNING: (guile-user): imported module (guix build utils) overrides
> > core binding `delete'
> > ;;; WARNING: loading compiled file
> >
> /gnu/store/62gvwndkddaq6203mrisshgiv13kkgcd-module-import-compiled/gnu/build/bootloader.go
> > failed:
> > ;;; In procedure load-thunk-from-memory: incompatible bytecode kind
> > ;;; compiling
> >
> /gnu/store/wamhgn5mhgzf9mgp9gxx3w6jn64hw4yc-module-import/gnu/build/bootloader.scm
> > ;;; compiled
> >
> /root/.cache/guile/ccache/3.0-LE-8-4.2/gnu/store/wamhgn5mhgzf9mgp9gxx3w6jn64hw4yc-module-import/gnu/build/bootloader.scm.go
> > guix system: bootloader successfully installed on '/boot/efi'
> > WARNING: (guile-user): imported module (guix build utils) overrides
> > core binding `delete'
>
> All these warnings are harmless and stem from the Guile 2.2/3.0
> transition. Specifically, it comes from the fact that ‘guix system
> reconfigure’ evaluates this code with the host Guile (in this case 3.0),
> whereas the modules are built for 2.2, which is what the Shepherd
> depends on.
>
> The culprit is ‘local-eval’ in (guix scripts system), which simply uses
> ‘primitive-eval’ to evaluate the code, thus disregarding the Guile
> version that should be used.
>
> One possibility would be to instead evaluate the expression in a
> separate Guile process for the intended Guile version.
>
> I’m not sure it’s worth it though. The warnings will hopefully
> disappear soon when we upgrade everything to 3.0.
>
> Thoughts?
>

I believe it is ok to wait until the transition complete.


Toggle quote (5 lines)
> Ludo’.
>
>
>
>
Attachment: file
L
L
Ludovic Courtès wrote on 2 Apr 2020 14:19
(address . strypsteen@posteo.net)(address . 39301-done@debbugs.gnu.org)
875zehmvpr.fsf@gnu.org
Hi,

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (13 lines)
> strypsteen@posteo.net skribis:
>
>> Whenever running "sudo guix system reconfigure /path/to/config.scm I
>> get the following warnings:
>>
>> building
>> /gnu/store/vpazjd711byj3jszh7jrk5d8lq51077g-switch-to-system.scm.drv...
>> ;;; WARNING: loading compiled file
>> /gnu/store/5bd6ywmfcxxa4gvpzg0pdbjwmf24cxkl-module-import-compiled/gnu/build/activation.go
>> failed:
>> ;;; In procedure load-thunk-from-memory: incompatible bytecode kind
>> ;;; compiling

[...]

Toggle quote (13 lines)
> All these warnings are harmless and stem from the Guile 2.2/3.0
> transition. Specifically, it comes from the fact that ‘guix system
> reconfigure’ evaluates this code with the host Guile (in this case 3.0),
> whereas the modules are built for 2.2, which is what the Shepherd
> depends on.
>
> The culprit is ‘local-eval’ in (guix scripts system), which simply uses
> ‘primitive-eval’ to evaluate the code, thus disregarding the Guile
> version that should be used.
>
> One possibility would be to instead evaluate the expression in a
> separate Guile process for the intended Guile version.

It turns out to be easy to implement, and better than let people be
confused when they install the new release.

Done in commit 5517750344be05c91bc2979c1a0e2348a9ae902d.

Thanks,
Ludo’.
Closed
L
L
Ludovic Courtès wrote on 3 Apr 2020 03:59
Re: bug#39301: closed (Re: bug#39301: imported module (guix build utils) overrides core binding `delete')
877dywltqs.fsf@gnu.org
Hi,

help-debbugs@gnu.org (GNU bug Tracking System) skribis:

Toggle quote (8 lines)
>> One possibility would be to instead evaluate the expression in a
>> separate Guile process for the intended Guile version.
>
> It turns out to be easy to implement, and better than let people be
> confused when they install the new release.
>
> Done in commit 5517750344be05c91bc2979c1a0e2348a9ae902d.

That was misguided because it removed all error checks.

Fixed in 9fb3ff31c15f36545bad11c1d9b11eaf0333f831, this time for good, I
hope!

Ludo’.
M
M
M
Maxime Devos wrote on 26 Feb 2023 15:27
Guile warnings printed upon reconfigure due to 3.0/2.2 mismatch
8161f9f0-7ad1-2e79-e8fb-e9af23fa31b7@telenet.be
These kind of errors happen again:
$ guix system build /etc/config.scm
/etc/config.scm:233:14: waarschuwing: the 'target' field is deprecated,
please use 'targets' instead
substitute: lijst van substituten van ‘https://ci.guix.gnu.org’ aan het
bijwerken... 100.0%
substitute: lijst van substituten van ‘https://bordeaux.guix.gnu.org’
aan het bijwerken... 100.0%
substitute: lijst van substituten van ‘https://substitutes.nonguix.org’
aan het bijwerken... 100.0%
The following derivations will be built:
/gnu/store/f0s8dnja8qli9qclpprlkj43nma54pm2-system.drv
/gnu/store/2qlkyj3cgbfykqg3frqmyadq8k2brckn-boot.drv
/gnu/store/mcilwp3nrjh8sg6fw98xs2j1bk3s5da4-shepherd.conf.drv
/gnu/store/023jq2rnz9ilww080676qwnl2arz2q80-shepherd-cups.go.drv
/gnu/store/7kgzwyy4rajwdkm6qgb11asgpqxb2pfw-shepherd-cups.scm.drv
/gnu/store/7kgzwyy4rajwdkm6qgb11asgpqxb2pfw-shepherd-cups.scm.drv bouwen...
/gnu/store/7kgzwyy4rajwdkm6qgb11asgpqxb2pfw-shepherd-cups.scm.drv
succesvol gebouwd
/gnu/store/023jq2rnz9ilww080676qwnl2arz2q80-shepherd-cups.go.drv bouwen...
;;; WARNING: loading compiled file
/gnu/store/4nw0zb4swga0cb8i35nvng3rg6z5qm8p-shepherd-0.9.3/lib/guile/3.0/site-ccache/shepherd/service.go
failed:
;;; In procedure load-thunk-from-memory: incompatible bytecode version
;;; WARNING: loading compiled file
/gnu/store/4nw0zb4swga0cb8i35nvng3rg6z5qm8p-shepherd-0.9.3/lib/guile/3.0/site-ccache/shepherd/support.go
failed:
;;; In procedure load-thunk-from-memory: incompatible bytecode version
;;; WARNING: loading compiled file
/gnu/store/4nw0zb4swga0cb8i35nvng3rg6z5qm8p-shepherd-0.9.3/lib/guile/3.0/site-ccache/shepherd/config.go
failed:
;;; In procedure load-thunk-from-memory: incompatible bytecode version
;;; WARNING: loading compiled file
/gnu/store/4nw0zb4swga0cb8i35nvng3rg6z5qm8p-shepherd-0.9.3/lib/guile/3.0/site-ccache/shepherd/comm.go
failed:
;;; In procedure load-thunk-from-memory: incompatible bytecode version
;;; WARNING: loading compiled file
/gnu/store/4nw0zb4swga0cb8i35nvng3rg6z5qm8p-shepherd-0.9.3/lib/guile/3.0/site-ccache/shepherd/system.go
failed:
;;; In procedure load-thunk-from-memory: incompatible bytecode version
/gnu/store/023jq2rnz9ilww080676qwnl2arz2q80-shepherd-cups.go.drv
succesvol gebouwd
/gnu/store/mcilwp3nrjh8sg6fw98xs2j1bk3s5da4-shepherd.conf.drv bouwen...
/gnu/store/mcilwp3nrjh8sg6fw98xs2j1bk3s5da4-shepherd.conf.drv succesvol
gebouwd
/gnu/store/2qlkyj3cgbfykqg3frqmyadq8k2brckn-boot.drv bouwen...
/gnu/store/2qlkyj3cgbfykqg3frqmyadq8k2brckn-boot.drv succesvol gebouwd
/gnu/store/f0s8dnja8qli9qclpprlkj43nma54pm2-system.drv bouwen...
/gnu/store/f0s8dnja8qli9qclpprlkj43nma54pm2-system.drv succesvol gebouwd
/gnu/store/fw1da6r6y4f1k8ddrfq4rr5xlgm9gzsc-system
Greetings,
Maxime.
Attachment: OpenPGP_signature
?