Do not show unsupported versions as upgradeable

  • Open
  • quality assurance status badge
Details
2 participants
  • francismb
  • Ludovic Courtès
Owner
unassigned
Submitted by
francismb
Severity
important
F
F
francismb wrote on 4 Dec 2023 09:45
(address . bug-guix@gnu.org)
d2d4de55-301e-4cc2-bcf3-1f9b2c0b3e61@email.de
Dear Guix Maintainer Team,
I've currently 'guix pull'-ed

$ guix describe
guix 597f1cd
branch: master
commit: 597f1cd1c46ffb92c3e0145de0071545a4c64865

and I'm able to upgrade all packages individually but on "glibc-locales"
I get:

$ guix upgrade glibc-locales
guix upgrade: warning: Consider running 'guix pull' followed by
'guix package -u' to get up-to-date packages and security updates.

The following package will be upgraded:
glibc-locales 2.35 → 2.37

guix upgrade: error: package glibc-locales@2.37 does not support
x86_64-linux


IMHO the package manager is telling me: "that package could be upgraded
(-n)", but when I try to, then isn't supported? I'm not sure if that's
some misunderstanding on my side or may be one (potentially) useful
improvement to: ¨do not show unsupported versions" as upgradeable?

Thanks in advance,
francisMB
L
L
Ludovic Courtès wrote on 8 Dec 2023 10:03
control message for bug #67627
(address . control@debbugs.gnu.org)
87ttosa7x2.fsf@gnu.org
severity 67627 important
quit
?